Skip to main content

How do I fix SSO errors?

Errors that you might encounter with SSO

D
Written by Daria Nasedkina

Overview

If SSO reports an error, find the matching error code below to understand the cause and apply the recommended solution.

401 Unauthorized

Problem: A user has successfully authenticated with their identity provider, but iHasco won't authorise a session because SSO has been configured to only allow access for registered users. Other SSO users are accessing iHasco without a problem.

Fix: Add the user manually (or via bulk upload), or modify the SSO configuration to allow access to unregistered users (this is the default).

Still a problem, or affects all users? Check that the SSO configuration is correct (IDP configuration may have changed), and that the security registration method is set to Single Sign On provider in the LMS.

422 Unprocessable Entity

Problem: The required user attributes (email address, first name, and last name) have been incorrectly mapped, or the IDP is now sending different attribute names.

Fix: Check that the SSO user attribute configuration is correct (IDP attribute names may have changed).

404 Not Found

Problem: An authentication URL was manually (mis)typed by a user.

Fix: There should be no need for users to enter any authentication URLs — SSO users only need to visit their iHasco training URL.

403 Forbidden

Problem: The SAML security assertion has already been sent. This is a security measure to prevent replay attacks.

Fix: The user should close the browser and re-attempt login.

405 Method Not Allowed

Problem: The identity provider is attempting to initiate an SSO flow.

Fix: iHasco only supports service-provider-initiated SSO. The identity provider must be configured with a start URL set to the iHasco training URL.

Still need help?

If you can't resolve the error using the guidance above, see I can't resolve SSO issues, what should I do?

Did this answer your question?